KernelCare supports a large number of distributions and kernel versions. List of all supported distributions, kernels, as well as patches for them is available at http://patches.kernelcare.com.

However, to be absolutely sure your kernel is supported, we have a simple script that you can run on your server.

https://github.com/iseletsk/kernelchecker/blob/master/py/kc-compat.py

It can be executed by running:

curl -s https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python

Or …

wget -qq -O – https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py|python

The script will respond with:

  • COMPATIBLE -> kernel supported by KernelCare
  • UNSUPPORTED -> KernelCare doesn’t recognize the kernel
  • UNSUPPORTED; INSIDE CONTAINER -> running inside the container, unable to patch kernel

If you have any questions, don’t hesitate to get in touch

Have Questions?

If you'd like to schedule a demo of KernelCare, have questions, or with trial and sales inquiries, please call us at +1 (201) 720-2340, email [email protected], or fill out this form.